In diesem Tutorial / Anleitung stelle ich Euch die Funktion SVERWEIS in Excel vor.  Ich arbeite zwar mit Excel 2007, dieses ist in allen für den SVERWEIS relevanten Funktionen aber identisch mit älteren und neueren Versionen.

 

Der SVERWEIS ist eine sehr nützliche Funktion, um irgendwo in einer Excel-Arbeitsmappe einen bestimmten Wert zu finden und abhängig davon einen weiteren Wert woanders auszugeben. Bevor wir uns mit einem Beispiel beschäftigen, schauen wir uns zunächst mal die Syntax an.

SVERWEIS (Suchkriterium; Matrix; Spaltenindex; Bereich_Verweis)

 

Das Suchkriterium ist dabei immer der Wert, der gesucht werden soll. Dieser kann entweder manuell eingegeben werden, z.B. als „Deutschland“, oder als Bezug, z.B. A1, gesetzt werden. Letzteres ist natürlich wesentlich mächtiger.

 

Als Matrix müssen immer mindestens zwei Spalten eingegeben werden, eine davon muss das Suchkriterium enthalten, z.B. A1:B5.

 

Der Spaltenindex gibt als Nummer die Spalte an aus der ein entsprechender Wert zurückgegeben werden soll.

 

Bereich_Verweis ist entweder 0 oder 1. 0 bedeutet dabei, dass eine exakte Übereinstimmung mit dem Suchkriterium gefunden werden soll (notwendig bei Texten), 1, dass ein Wert, der ungefähr dem Suchkriterium entspricht, ausgegeben wird, z.B. statt 1 wird 0,99 gefunden und ausgegeben.

 

Ein einfaches Beispiel für den SVERWEIS ist folgender Fall:

 

Angenommen auf Blatt 1 stehen in den Spalten A1 bis B5 Artikel und die dazugehörigen Preise. In einer anderen Tabelle auf Blatt 2 stehen in den Spalten C1 bis E5 die Artikel, die Farbe und die Größe. Letztere beiden Eigenschaften sollen nun in den Spalten C1 bis D5 auf Blatt 1 ausgegeben werden.

 

Die entsprechende Formel dazu lautet dann in Zelle C1:

=SVERWEIS(A1;Blatt2!’$C$1:$E$5;2,0)

und in D1:

=SVERWEIS(A1;Blatt2!’$C$1:$E$5;3,0)

 

Diese Formel kann dann einfach herunterkopiert werden.

 

Noch ein abschließendes Wort zum SVERWEIS. Damit dieser funktioniert muss das Suchkriterium in der Suchmatrix immer links von den Werten stehen, die ausgegeben werden soll, da der SVERWEIS nur nach rechts, nicht aber nach links, suchen kann. Ferner kann der SVERWEIS nur ein Suchkriterium umfassen.

 

Um diese Nachteile zu umgehen sind andere Funktionen notwendig, vor allem sogenannte Matrixformeln, denen wir uns an anderer Stelle einmal widmen werden.